Re: [load balancing] VRRP failover (Active-Hotstandby) not working on alteon ad3

From: Oliver Adam <oadam [izzat] madao.de>
Date: Tue Aug 14 2007 - 06:39:22 EDT

Jens is correct at least because the hot-standby ports are mussing
and there is as well not "interswitch" port configured.

The prios are not very important here because switch 1 is the OWNER
the VRRP address (its own physical IP is the same as the VRRP IP).
What I wonder about is that this is NOT a active-hot standby
configuration. This is maybe active-standby but for sure not hot
standby. You might mix the names up but hot standby requires ports to
be defined as hot-standby ports.

STP is NOT turned off on the second Alteon - very bad. This is always
resulting in delays you do not want to have in such a setup. Some
virtual servers are not reachable? Where is the virtual server
configuration? You have mentioned some virtual servers where not
reachable... have you checked the FDB/ARP cache of connected devices
to see the addresses actually moving to the other Alteon? An option
might be to define so called VSRs (virtual server routers) on top of
the virtual servers to have a failover together with the VRRP addresses...

At 10:17 14.08.2007, you wrote:
>Ok, now with the correct account ;)
>
>Hi,
>
>only a short look ;)
>
>I see identical prios on vrrp.
>Set the master to 200 and the backup to 100.
>
>If you use the AD3 in a Hot-Standby configuration, i didn't see in your
>setup the configuration for the hot-standby port or i am blind ;)
>hotstan enabled for the failover port is the parameter i think. You
>found them under /c/sl/port xx/hotstan enabled
>
>Can you post the infos from /info/l3/vrrp from both devices?
>
>Regards,
>
>Jens
>
>
>
>
>Anil Oza schrieb:
> >
> > HI,
> >
> >
> >
> > I have 2 Nortel alteon AD3.
> >
> >
> >
> > I have done the Config as per documents for active-hot standby. When I
> > restart master, backup become master but not able to access all
> > virtual servers.
> >
> >
> >
> > Also, happened as soon as I enabled hot standby on both ad3, I lost
> > the ping of one Alteon.
> >
> >
> >
> > Current physical layout:
> >
> > |firewall| |firewall|
> >
> > | |
> >
> > \ /
> >
> > \ /
> >
> > |switch|
> >
> > | |
> >
> > / \
> >
> > / \
> >
> > |alteon| |alteon|
> >
> > | |
> >
> > \ /
> >
> > |switch|
> >
> > | |
> >
> > \ /
> >
> > |server|
> >
> >
> >
> > Alteon 1:
> >
> > =============
> >
> > /c/port 1
> >
> > pvid 10
> >
> > /c/port 1/fast
> >
> > speed 100
> >
> > fctl both
> >
> > mode full
> >
> > auto off
> >
> > /c/port 2
> >
> > pvid 10
> >
> > /c/port 2/fast
> >
> > speed 100
> >
> > fctl both
> >
> > mode full
> >
> > auto off
> >
> > /c/port 3
> >
> > pvid 10
> >
> > /c/port 3/fast
> >
> > speed 100
> >
> > fctl both
> >
> > mode full
> >
> > auto off
> >
> > /c/port 7/fast
> >
> > speed 100
> >
> > fctl both
> >
> > mode full
> >
> > auto off
> >
> > /c/vlan 1
> >
> > def 4 5 6 7 8 9
> >
> > /c/vlan 10
> >
> > ena
> >
> > name "STAGING"
> >
> > def 1 2 3
> >
> > /c/stp 1/off
> >
> > /c/stp 1/clear
> >
> > /c/stp 1/add 1 10
> >
> > /c/sys/syslog
> >
> > host 192.168.10.213
> >
> > /c/ip/if 2
> >
> > ena
> >
> > addr 192.168.10.10
> >
> > vlan 10
> >
> > /c/ip/gw 1
> >
> > ena
> >
> > addr 192.168.10.1
> >
> > /c/ip/dns
> >
> > prima 192.168.10.211
> >
> > dname st46.asite.com
> >
> > /c/vrrp/on
> >
> > /c/vrrp/vr 1
> >
> > ena
> >
> > vrid 1
> >
> > if 2
> >
> > prio 200
> >
> > addr 192.168.10.10
> >
> > share dis
> >
> > /c/vrrp/group
> >
> > ena
> >
> > vrid 1
> >
> > if 2
> >
> > prio 200
> >
> > share dis
> >
> > /c/sys/ntp
> >
> > on
> >
> > server 17.72.133.42
> >
> > /c/slb
> >
> > on
> >
> > /c/slb/adv
> >
> > direct ena
> >
> > pmask 255.255.255.0
> >
> >
> >
> >
> >
> > =============
> >
> > Alteon 2:
> >
> > =============
> >
> >
> >
> > /c/port 1
> >
> > pvid 10
> >
> > /c/port 1/fast
> >
> > speed 100
> >
> > fctl both
> >
> > mode full
> >
> > auto on
> >
> > /c/port 2
> >
> > pvid 10
> >
> > /c/port 2/fast
> >
> > speed 10
> >
> > fctl both
> >
> > mode full
> >
> > auto on
> >
> > /c/port 3
> >
> > pvid 10
> >
> > /c/port 7
> >
> > pvid 10
> >
> > /c/port 7/fast
> >
> > speed 100
> >
> > fctl both
> >
> > mode full
> >
> > auto on
> >
> > /c/vlan 1
> >
> > def 4 5 6 8 9
> >
> > /c/vlan 10
> >
> > ena
> >
> > name "VLAN 10"
> >
> > def 1 2 3 7
> >
> > /c/stp 1/clear
> >
> > /c/stp 1/add 1 10
> >
> > /c/ip/if 2
> >
> > ena
> >
> > addr 192.168.10.11
> >
> > vlan 10
> >
> > /c/ip/gw 1
> >
> > ena
> >
> > addr 192.168.10.1
> >
> > /c/vrrp/vr 1
> >
> > ena
> >
> > vrid 1
> >
> > if 2
> >
> > addr 192.168.10.10
> >
> > share dis
> >
> > /c/vrrp/group
> >
> > ena
> >
> > vrid 1
> >
> > if 2
> >
> > prio 200
> >
> > share dis
> >
> >
> >
> > ======================================
> >
> >
> >
> > Any help would be appreciated.
> >
> >
> >
> > Thanks!
> >
> > Anil Oza
> >
> > ------------------------------------------------------------------------
> >
> > _______________________________________________
> > lb-l mailing list
> > lb-l@vegan.net
> > http://vegan.net/mailman/listinfo/lb-l
> > Searchable Archive: http://vegan.net/lb/archive
> > http://lbdigest.com Load Balancing Digest
>
>
>--
>Linus Torvalds:
>"Only wimps use tape backup: _real_ men just upload their important
>stuff on ftp, and let the rest of the world mirror it"
>
>
>_______________________________________________
>lb-l mailing list
>lb-l@vegan.net
>http://vegan.net/mailman/listinfo/lb-l
>Searchable Archive: http://vegan.net/lb/archive
>http://lbdigest.com Load Balancing Digest

_______________________________________________
lb-l mailing list
lb-l@vegan.net
http://vegan.net/mailman/listinfo/lb-l
Searchable Archive: http://vegan.net/lb/archive
http://lbdigest.com Load Balancing Digest
Received on Tue Aug 14 06:39:53 2007

This archive was generated by hypermail 2.1.8 : Tue Aug 14 2007 - 06:39:53 EDT