RE: [load balancing] Need help with Alteon 3408 & Solaris IPMP

From: Mike Terlouw <Mike.Terlouw [izzat] IonIP.com>
Date: Wed Apr 05 2006 - 07:23:03 EDT

Hi Khurram,
 
Client processing seems to be missing on of your slb/ports in the config.
 
Cheers, Mike
 
 

  _____

Van: Khurram Tariq [mailto:khurramtm@gmail.com]
Verzonden: woensdag 5 april 2006 11:58
Aan: lb-l@vegan.net
Onderwerp: [load balancing] Need help with Alteon 3408 & Solaris IPMP

Hi,

I have two Alteon 3408 running in a redundant configuration. The servers &
the virtual IP are on the same subnet. The servers are Sun Solaris 9 boxes
running IPMP & the connecitivty is like this:

_________ _________
| Alteon 1 | | Alteon 2 |
---------------- ----------------
    | \ / |
    | \ / |
    | /\ |
    | / \ |
    | / \ |
  Server 1 Server 2

I've configured the real servers, real group, virtual server & configured
the ports as server. The application I want to load balance is Apache
running on port 80. The virtual server is pingable & accessible from the
Alteon only & not from the boxes on the same subnet. When I checked the ARP
able on the Alteon I saw that the VIP I've configured ( 172.16.2.42
<http://172.16.2.42> ) does not have any VLAN ID against it. See below:

>> Address Resolution Protocol# dump
    IP address Flags MAC address VLAN Age Port Referenced SPs
  --------------- ----- ----------------- ---- --- ----- ----------------
  172.16.2.15 <http://172.16.2.15> 00:03:ba:9d:41:75 1 35
2 empty
  172.16.2.16 <http://172.16.2.16> 00:03:ba:96:f7:6b 1 36
2 empty
  172.16.2.18 <http://172.16.2.18> 00:03:ba:2c:ec:82 1 36
2 empty
  172.16.2.19 <http://172.16.2.19> 00:03:ba:86:36:d7 1 36
2 empty
  172.16.2.39 <http://172.16.2.39> 00:03:ba:f2:9f:ae 1 36
7 empty
  172.16.2.42 <http://172.16.2.42> P 4 00:11:f9:c9:33:0e
1-4
  172.16.2.55 <http://172.16.2.55> P 00:11:f9:c9:33:00 1
1-4
  172.16.2.56 <http://172.16.2.56> P 4 00:00:5e:00:01:09 1
1-4
  172.16.2.57 <http://172.16.2.57> P 4 00:00:5e:00:01:07 1
1-4
  172.16.2.130 <http://172.16.2.130> 00:08:7c:bc:b0:40 1 36
2 empty

The configuration I've done is:
----------------------------------------------------------------------------
----------------------------
/cfg/slb/real 5
rip 172.16.2.38 <http://172.16.2.38>
ena

/cfg/slb/real 6
rip 172.16.2.39 <http://172.16.2.39>
ena

/cfg/slb/group 3
add 5
add 6
metric round
health tcp

/cfg/slb/virt 3
vip 172.16.2.42 <http://172.16.2.42>
ena
service http
group 3

/cfg/slb/port 7
server e

/cfg/slb/port 8
server e
----------------------------------------------------------------------------
----------------------------

What can be the reason for this? All 8 ports are in the same VLAN & the
Alteons already are running two different virtual servers fine with VRRP.
I'll appreciate the help

____________________
The Load Balancing Mailing List
Unsubscribe: mailto:majordomo@vegan.net?body=unsubscribe%20lb-l
Archive: http://vegan.net/lb/archive
LBDigest: http://lbdigest.com
MRTG with SLB: http://vegan.net/MRTG
Hosted by: http://www.tokkisystems.com
Received on Wed Apr 5 07:23:21 2006

This archive was generated by hypermail 2.1.8 : Wed Apr 05 2006 - 07:43:23 EDT