Re: [load balancing] CSS hangs after 16Mb of traffic into GE port for transparent proxies

From: Stephane Litkowski (st_litkowskiIZZAThotmail.com)
Date: Tue Feb 05 2002 - 09:51:40 EST

  • Next message: Allan Liska: "[load balancing] SSL Session ID Load Balancing"

    URL analysis is not ASIC , it's CPU only ...
    Only L4 switching is done by ASICs (Fast Path Processors).
    The 'url "/*"' in your config make the CSS do CPU switching instead of ASIC
    switching : in your case, CSS CPU (SFP = Switch Fabric Processor) does L7
    analysis for each packet.

    >From: Benny Chee <bennycIZZATmagix.com.sg>
    >Reply-To: lb-lIZZATvegan.net
    >To: lb-lIZZATvegan.net
    >Subject: Re: [load balancing] CSS hangs after 16Mb of traffic into GE port
    >for transparent proxies
    >Date: Tue, 5 Feb 2002 22:08:27 +0800
    >
    >just found out another thing, once traffic goes through the switch, the cpu
    >shot up from 4% to 80% at 10Mb load. What's wrong, i thought it's ASIC?
    >
    >CPU utilisation was done using "show system-resource" command. I m running
    >5.00 Build 33 code.
    >
    >benny
    >
    >On Sun, Feb 03, 2002 at 10:12:35AM +0800, Benny Chee wrote:
    >| hi,
    >|
    >| did anyone have the following sympton....
    >|
    >| i was running up my CSS11154 to do transparent proxies load balancing.
    >my router would intercept port 80 request and forward it to the circuit
    >VLAN of my CSS. i have 6 caches (cacheflow) sitting behind the CSS. All's
    >being balance using domainhash method. The caches points default route to
    >the CSS, and the CSS points default route to my router.
    >|
    >| after 10mins and 16Mb of traffic later, all traffic stops at the CSS,
    >and it just hangs. No traffic could pass through. A hard reset to the CSS
    >was the only solution. Can't even telnet to the mgmt port.
    >|
    >| Does someone on the list have similar network configurations and got
    >things to work? If so, how? What version of CSS is more stable?
    >|
    >| after the incident, i upgraded from ver 5.00 build 2 to ver 5.00 build
    >33. Still the same problem persists. Any help?
    >|
    >| attached is part of my config.
    >|
    >|
    >| !*************************** GLOBAL ***************************
    >| persistence reset remap
    >| ip opportunistic all
    >|
    >| ip route 0.0.0.0 0.0.0.0 192.168.1.254 1
    >|
    >| !*************************** OWNER ***************************
    >| owner foo.com
    >|
    >| content transparent_proxy
    >| balance domainhash
    >| add service cf3
    >| add service cf4
    >| add service cf5
    >| add service cf6
    >| add service cf7
    >| add service cf8
    >| protocol tcp
    >| port 80
    >| url "/*"
    >| no persistent
    >| active
    >|
    >| benny
    >| ____________________
    >| The Load Balancing Mailing List
    >| Unsubscribe: mailto:majordomoIZZATvegan.net?body=unsubscribe%20lb-l
    >| Archive: http://vegan.net/lb/archive
    >| LBDigest: http://lbdigest.com
    >| MRTG with SLB: http://vegan.net/MRTG
    >| Hosted by: http://www.tokkisystems.com
    >____________________
    >The Load Balancing Mailing List
    >Unsubscribe: mailto:majordomoIZZATvegan.net?body=unsubscribe%20lb-l
    >Archive: http://vegan.net/lb/archive
    >LBDigest: http://lbdigest.com
    >MRTG with SLB: http://vegan.net/MRTG
    >Hosted by: http://www.tokkisystems.com
    >

    _________________________________________________________________
    Get your FREE download of MSN Explorer at http://explorer.msn.com/intl.asp.

    ____________________
    The Load Balancing Mailing List
    Unsubscribe: mailto:majordomoIZZATvegan.net?body=unsubscribe%20lb-l
    Archive: http://vegan.net/lb/archive
    LBDigest: http://lbdigest.com
    MRTG with SLB: http://vegan.net/MRTG
    Hosted by: http://www.tokkisystems.com



    This archive was generated by hypermail 2b30 : Tue Feb 05 2002 - 09:59:36 EST